WordPress rilascia una nuova versione dopo la vulnerabilità. Pronta da installare la 4.2.2

2015-05-08T11:11:00+00:00 08/maggio/2015 |Siti Internet|

wordpressLa notizia è circolata in rete soprattutto ieri, quando WordPress ha parlato di una pesante vulnerabiità presente sui suoi sistemi. In particolare è stato individuato un bug XSS (Cross Site Scripting) nel pacchetto Genericons usato da diversi temi e da molti plugin.

I problemi sono stati risolti nella versione 4.2.2 che andrebbe installata quanto prima in modo da evitare possibili criticità.

Una versione aggiornata infatti permette un maggior controllo sulle funzionalità e di superare le problematiche emerse a seguito di vulnerabilità.

Da quanto emerge online, la vulnerabilità riguarda il Document Object Model, relativo a testi, immagini e link. Un attacco difficile da bloccare perché la pagina non subisce modifiche ma il bug permette di eseguire JavaScript che non consentono il corretto funzionamento della visualizzazione di testi, immagini e altro contenuto. Con l’eliminazione di file example.html nel pacchetto Generincons, soluzione adottata dagli sviluppatori, si supera il problema e si risolvono i vari bug.

Il suggerimento è sempre quello di aggiornare in tempo le tante versioni, riuscendo a superare così le difficoltà generate da codice e dai vari bug.